Knowledge Base

Notice Information in this article applies to Excelsior JET versions 3.0 through 3.7.

SYMPTOMS

You have the Java Runtime Environment (JRE) installed in a certain directory on your system, but JET Setup does not display it in the list of JREs found.

CAUSE

JET Setup uses Windows registry to find the JREs installed on your system. So, for instance, if you copy a JRE from another computer instead of doing a proper install, there will be no registry entry for that JRE. Similarly, if you rename or move the JDK/JRE directory after installation, the respective registry entry will contain a wrong pathname. In either case, JET Setup will not be able to find that JRE automatically.

JET Setup will also not list the JRE if it does not pass compatibility/consistency checks. See Article 000007 for details.

Finally, Excelsior JET, Personal Edition may only work with a non-redistributable JRE, which is installed as part of the respective JDK, so JET Setup in the Personal Edition will not display a redistributable JRE.

This behavior is by design.

RESOLUTION

Click Browse and select the directory containing the desired JRE. If it is rejected, see Article 000007 for details on possible causes and resolution.

If using Excelsior JET, Personal Edition, install the desired version of the JDK and re-run JET Setup.

REFERENCES

  1. Article 000007
  2. Archived Java 2 releases at java.sun.com

Article ID: 6
Last Revised On: 26-Sep-2005